Sometimes your Moodel server will not play well with the version of the Amazon Web Services(AWS) SDK that we user. In that case please choose Version 2 and see if it makes difference. Do that at:

Site administration -> Plugins -> Filters -> Poodll Filter -> General Settings